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Creating an Object Model from an Entity Model

1.

Download Computer Sales.vpp. You can also find this file at the bottom of this tutorial, under the
Resources section.

Open the downloaded project file in Visual Paradigm. You can open a project by selecting
Project > Open from the application toolbar.

Before we continue, there is one important point to note here. In this tutorial, we are going

to generate ORM code and Hibernate mapping that can work with an Oracle database. It is
important to configure the database setting by selecting Oracle as your database. Let's check.
Select Tools > DB > Database Configuration... from the application toolbar. We have selected
Oracle for you in the Database Configuration window. Remember to do this yourself in a real
case. Besides, make sure you have entered the connection details as well for actual usage. But
to complete this tutorial, we can leave the connection settings unfilled. Let's close the Database
Configuration now.

[+ Database Configuration “

Language: |Java w

D [ ]MysaL Database Setting

D [[] MariaD& Driver : Oradlesif10g {or above) v | W

%% Server Driver file : v \Fl/
acle] =

[ [hHsqL : :

Connection URL : Production

[ [ sybase AsE Ed

[} [ sybase SQL Anywhere @) Hostname :

[} []PostgresqL

[} [ Cloudscape /Derby Database name :

[ [Joe2

1 M thares () lidberorade:thin: @<host name=:<port number=:<database name>
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records.
4 Add N Computer B 4 Computer_Computer_Part 0
| id number(10) | id number(10) 0 % computer_id number(10)
B cust_id number(10) ™ computer_category id  number(10) T computer_part_id  number(10)
[F] address 1 varchar2255) [\] reg_date timestamp N ~
[5] address 2 varchar2(255) [ 5] tite varchar2255)  [] - ~
[[] address_3 varchar2255) [}] [£] price number(8, 2} IN| T : a“(::M :01
city varchar2(64) Y] computer_desc varchar2(1024) [}  desc v 024 [
country varchar284) ] 5] remark varchar2(255)  [ho i
L] =5 L= remark varchar2(255) ]
zip_code  varhar2(12)  [}f] ) B model varchar2(4) Il‘l "o J
T
R |
JI. |
d Payment_Status B d Customer D
|/ status_code  number(10) i id number(10) X a Manufacturer B
payment_desc varchar2(255) [}(] cellphone varchar220) [} - T e number(10)
= T - [5] email_address wvarchar2(128) [ ! ! short_name varchar2(50) [
i J_l _: : : full_name varchar2(255) m
Qe Q o ] contact vachar2z0)  [§]
C Computer_Payments 0 C Computers_Sold B . -
| id number(10) | id number{10) O !
= cust_id number10) = cust_id number(10) D ?
*% payment_status_code  number(10) 4 *= computer_id  number(10) Do C _ Computer_Part
¥ parts_sold_id number(10) agreed price number(8,2) [] o ! ! d number(10)
‘ﬁ-,conpum_so:d_ﬂ number(10) [5] date timestamp IN| i | P manufacturer i number10)
remark varchar2(255) [} | name varchar2(255)  []
Eﬁ - / ! price number(8 2} [}f]
i p N ! comp_part desc varchar2(1024) [\]
Parts_Sold i | [£] remark varchar2(255) [
I -
! o number(10) X model varchar2(54) N
| = cust_id number(10) BO- - - -
\ % computer_part id  number(10) B
bommmmmmmm e A ] computer_id L N | O K
agreed_price numben8, 2 [}
date timestamp IN|
x remark number(255) m]j

Open the Entity Relationship Diagram (ERD) Computer Sales and take a look. The diagram
contains a number of entities related to an ordering system designed for storing computer sales

To generate the Hibernate mapping and ORM source files, you need to synchronize the ERD
and class diagram first. Right-click on the ERD and select Synchronize to Class Diagram.
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6. The Synchronize from Entity Relationship Diagram to Class Diagram window will appear.
Enter Class Model as the class diagram name and click OK.

Entity Relationship Diagram Class Diagram HETE

Computer Sales Class Mode Preview (791x...

Reset | | Ignore Entities when Synchronizing. ..

7. The Synchronize to Class Diagram screen will appear. We will just keep the class and
attribute names as suggested. Click OK to continue.

Target Parent : |Same as source model element
Object-and-R.elational Mapping
Entity / Column Class [ Attribute

email_address
Addresses

id

address_1

address_2

address_3

dty

country

zip_code
Parts_Sold

id

computer_id

agreed_price

date

remark
Computers_Sold

id

agreed_price

date

remark
Computer_Payments

id

| ExportMapping | | tmport Mapping | | Type Mapping Option |

[] Add <<PK>> stereotype to ID attribute
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8. Aclass diagram is produced based on the ERD.

<=0RM Persistable>> <<ORM Persistable>>
Addresses Comg
-id :int -id :int 0.
-address_1 : String -reg_date : Timestamp computer
-address_2 : String -title : String _
-address_3 @ Sting -price : BigDecimal <<ORM Persistable>>
-city : Stiing -computer_desc : String | 0.°  computer_category | Computer_Category
~country : String -remark : String computer 1 |-id vint
-zip_code : String -model : String -category_desc: String
-remark : String
addresses 0. computer | 1
1 | cust
<<0ORM Persistable>> <<0ORM Persistable>>
Payment_Status Customer 1 <<0ORM Parsistabla=>
-status_code : int -id : int st Manufacturer
-payment_desc: String -cellphone : String Lid - int
payment_status_code | 1 (e Hhl -shorl_name : String
cust 1 cust | 1 ~full_name : String
0. computer_Payments -contact : Sting
<<ORM Persistable>> | 0.~ .
0. i Sold
Computer_ Payments | computar_Payments compuiars_so manufacturer | 1
- <<0RM Parsistable>>
-id : int Sold 0. computer_Part
0.+ | computer_Payments T <<ORM Persistable>>
computer_Payments - o i * Computer_Part
puler_ray 0. computers_sold -agreed_price : BigDecimal 0. — 0.
-date : Ti tamp computers_Sold -id : int
1 |remark : String -name : String computer_part
-price : Big Decimal
~comp_part_desc : String
-remark : String
<<0RM Persistable>> -model : String
Parts_Sold
S int 0. computer_part | 4
-computer_id : Integer parts_Sold
parts_sold  |-agreed_price : BigDecimal
1 |-date : Timestamp 0.
-remark : Integer parts_Sokd

Generating ORM Source and Hibernate Mapping

1. There is a package header on top of the diagram, on the left-hand side. The package header
specifies the package where the classes under this diagram are stored. It affects both the
structuring of the model and the generated code. Without specifying any package header there,
classes will all be placed at the root, both in the model and in the generated code. Let's enter
a package name. Double-click on the package header and enter com.computersales as the
package header.

Class Model
com.computersales|
A
- N
o

2. To generate Hibernate mapping, select Tools > Hibernate > Generate Code... from the
application toolbar.
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3. Inthe Database Code Generation window, specify the output path of source files, Hibernate

mapping files, DDL, and library files.

Generate @ |Code and Databasze v |

Language : | Java v |

Output Path : |C:\JJsers\Peter\Dommems\,CcmputerSales

DeployTo: | Standalone Application

Framework : |I—E)emate HML v |
Error Handling : |T?'row PersistentException Y] |
Logaing : |Print to Error Stream vl

4. Click OK to start the generation.

5. Let's take a look at the generated files.

LN A L

Home Share WView

@ = 4 | « LocalDisk (C:) » Users » Peter » Documents » ComputerSales

-
MName

1 lib
1M This PC L sre
B buildxml

CompileAll.bat
g Computer5ales.dd|

7} Favorites

f! Metwork

RunCreateComputerSalesData.bat

RunCreateComputerbalesDatabasebche...

RunDeleteComputerSalesData.bat
RunDropComputer5alesDatabaseSchema...
RunlistComputerSalesData.bat
RunRetrievefindUpdateComputerSalesDa...
RunSample.bat

12 items

Date modified

3/16/2016 5:21 PM
3/16/2016 5:21 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
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v @
v & Search Comp... @

Type Size

File folder

File folder

XML File

Windows Batch File
DDL File

Windows Batch File
Windows Batch File
Windows Batch File
Windows Batch File
Windows Batch File
Windows Batch File
Windows Batch File
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6. The source files are placed at &#36;{outputPath}\src.

Home Share View

@ = 1 | « Documents » ComputerSales » src » com » computersales

-~

[ T} Favorites Narne

.'3 Addresses.java
| > 1% This PC .3 AddressesCriteria.java
7)) AddressesDAO java
b f' Metwork .3 AddressesDetachedCriteria.java
.'3 AddressesSetCollection.java
.'3 Computer.java
.'3 Computer_Category.java

.'3 Computer_CategoryCriteria.java

.'3 Computer_CategoryDAC java

.'3 Computer_CategoryDetachedCriteria.java
.'3 Computer_Part.java

.'3 Computer_PartCriteria.java

.'3 Computer_PartDAO java

.'3 Computer_PartDetachedCriteria.java

.'3 Computer_PartSetCollection.java

48 items

7. Let's open the generated source file.

Date modified

3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM
3/16/2016 5:20 PM

v G

Type

JAVA File
JAVA File
JAVA File
JAVA File
JAVA File
JAVA File
JAVA File
JAVA File
JAVA File
JAVA File
JAVA File
JAVA File
JAVA File
JAVA File
JAVA File

Tutorial

v e

Search comp.. @

Size

[ File Projects Edit Search View Format Tools HTML Settings Window Help [=1[2][x]
" 1. Addresses, java ]
9 BB B B B B S I 5 10 9,10
Sk ~
* "Vigpal Paradigm: DO NOT MODIFY THIS FILE!"
-
* This is an automatic generated file. It will be regenerated every time
* you generate persistence class.
* Modifying its content may cause the program not vork, or your vork may lost.
=F
S
* Licensee: Pester
* Licenss Typs: Purchased
-f
package com.computersales;
public class hAddresses= [f
public Addresses() {
1
private void this_setOwner (Object owner, int key) {
if (key == com.computersales.ORMConstancs HEY ADDRESSES CUST) {
this.cusc = (com.computersales.Customer) owner:
}
}
org.orm.util.ORMhdapter _ormAdapter = new org.orm.util.AbscractCRMAdapter() {
public void secCwner (Object owner, int key) {
This_setOwner (owner, key);
¥
b
private int id:
private com.computersales.Customer cust;
private String address 1;
private String address_2; v
16: 25/ 138 [2520] B = Java 005 Code page: UTF-8
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8.  The Hibernate mapping files are placed at &#36;{outputPath}\src\ormmapping.

Home Share View

@ ~ 1 . « ComputerSales » src » ormmapping » com » computersales v O

-~

ﬁ Favorites Mame Date modified Type

B Addresses.hbm xml 3/16/2016 5:20 PM XML File
1% This PC g Computer.hbm.ml 3/16/2016 5:20 PM XML File
B Computer_Categary.hbmaml 3/M16/2016 5:20 PM XML File
f' Metwork B Computer_Part.hbm.xml 316/2016 5:20 PM XML File
8 Computer_Payments.hbm.xml 3M6/2016 3:20 PM XML File
g Computers_Sold.hbm.xml 3/16/2016 5:20 PM XML File
B Customerhbm.ml 3/M16/2016 5:20 PM XML File
B Manufacturer.hbm.xml 316/2016 5:20 PM XML File
B Parts_Sold.hbm.xml 3/16/2016 5:20 PM XML File
g Payment_Status.hbm.xml 3/16/2016 5:20 PM XML File

10 items

9. Let's open the generated Hibernate mapping file.

v e
Search comp.. @

Size

(7 File Projects Edit Search View Format Tools HTML Settings Window Help BEE
1.. Addresses.hbm.xml

Mo cnniic odithonafnandith oo innn oo fiaos S oscions o oo it cofo codth oo oo dthann coodithanafion @it s fnn a0 o slinas i
I(?xm] varsion="1.0" ancoding="utf-8" 7>

<1

Licansaa: Patar
License Type: Purchased
=

<!DOCTYPE hibesrnate-mapping FUBLIC "-//Hibesrnate/Hibesrnate Mapping DTD 3.0//EN" |Mhttp://vev.hibernate.org/dtd/hibernate-mapy

<hibernate-mapping>
<class nane="Com.computersales. Addresses” table="Rddresses™ lazy="Ifalse"r
<id name="id" column="id" type="integer” unsaved-value="Q0">
<generator class="native"»
</generacor>
</id>

<many-To-one name=Tcust" cascade="lock" column="cust_id" class="com. les.C not-null="true” lazy="proxy’|

</many-to-cne>
<property name="address_1" column="address_ 1" type="string” length="255" not-n
<property name="address 2" column="address 2" type="string®™ length="255" not-m

l="false" lazy="false"/>
“false" lazy="false"/>

<property name="address 3" column="address 3" cype="scring"™ length="255" notinull="falsa" lazy="false"/>

<ProOperty name="city” column="city" TYPe=TITring” length="64" not-null="alse” lazy="false"/>
< t¥ name="Country" column="COUntriy¥" type="string™ length="64" no
<property name="zip code® column="zip code"” type="string™ length="13" r
</class>
</hibernate-mapping®

Resources
1. Computer Sales.vpp

Related Links
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. Tutorial - Define Custom Implementations for ORM Persistable class

. Tutorial - Begin UML Modeling in Eclipse

. Tutorial - Working with Hibernate in Eclipse

. User's Guide - Eclipse Integration

. What is Entity Relationship Diagram (ERD)?
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